FAQ

FAQ for 2c8 Modeling Tool and 2c8 Lite

 

2c8 Modeling Tool

Modeling

Press File (New Model) in the menu or Create new model on the start page.

newmodel

Choose model type, enter the name of your model and press OK.

namemodel

To navigate between models in 2c8 Modeling Tool, breakdowns to other models can be created from objects or relations.To create a new breakdown, right click on the object or relation and select “Breakdowns” and then “Create new”.

If there already exists breakdowns from an object or relation these will be visible from the breakdown menu. You can follow a breakdown to the model, or remove the breakdown from this menu.

It is possible to create multiple breakdowns from the same object, for instance to visualize current state and desired state or to visualize the model both as a regular model and as a swimlane model.

If you want to connect data directly on a model or an object you should use descriptions and fields.

If a description tab is missing for an object type you may need to connect the description to the object type. Double click on “Descriptions and fields” in the Browser to open a new tab in the drawing area. Right click on the description you want and choose “Connect to types”.

For each description/field you create you choose which type of values are allowed from the following list:

Text: A row with unformatted text.
Objects: Refers to an object of a given type in the repository.
Number: A number within given limits with a unit.
Formatted text: HTML formatted text which can contain tables, images etc.
Dropdown: A value that is chosen from a list of predefined values.

Quickdraw is activated in the toolbar and is used to quickly build a model from existing symbols.

Quickdraw icon

Hold the mouse over a symbol to show arrows in the directions where suggestions for relations to new symbols exist. Hold the mouse over an arrow to show the suggested symbols in that direction. When you click on a symbol you will get to choose a title in the same way as when you add a symbol by clicking in the model.

The keyboard shortcut to toggle Quickdraw is Ctrl+Q. If you want different suggestions in Quickdraw, this can be configured from 2c8 Administration Tool.

To adjust the color and size of headings and text in descriptions and how they are displayed in the published material you need to make the adjustments in the web profile you are using. This makes all descriptions on all objects and models use the same formatting.

Note that you can make different adjustments for every web profile you have.

 

If you open “Properties” – “Description” on a model or object there is a drop down that has the same name as your web profile. Choose a profile and the text in the description will preview what the text will look like in your published material.

To change these settings:

1. Select the web profile you want to use and click on the pen to edit (“Tools” – “Publish”).

2. Go to “Appearance” – “Theme”

3. Choose descriptions and adjust desired settings. (Normal = Paragraphs)

4. These settings correspond to the formatting options you see in the description dialog.

 

The size of the text is set in e.m’s. If you are used to other units, please see the table below:

Note that if you change fonts, size and color in the description dialog it will override the adjustments you have made in the web profile.

If you have removed a model by accident you can restore it by:

  1. Click on “Browser” in the left panel
  2. Double-click “Models” to open a new tab
  3. Click on the arrow for more options
  4. Click on the trash can with a clock on it
  5. Pick the model you want to restore

restore model 1

restore model

Load More

Repository

Press Create repository in the dashboard, you will then choose local or server:
newrepo2

Press File (Create repository) in the menu, or the plus sign in the toolbar:newrepo

Note that this repository is created locally. If you would like to create a new repository on your server just select the server tab and the press the plus sign in the toolbar.

Enter the name of your repository and then press OK.

namerepo

Create and restore backup of local repositories

If you store your local repositories on a place where there is no automatically backup it could be a good idea to create a backup.

You will find your local storage if you go to “Tools – Settings” in the menu and then choose “Local”.

A backup is also a convenient way to share a local repository with another user of 2c8 Modeling Tool.

Create a backup

  1. Open 2c8 Modeling Tool
  2. Choose the tab ”Local”
  3. Choose ”Tools – Backup repositories…” in the menu
  4. Select which repository you want to backup
  5. Click on “Create backup”
  6. Choose a file name and a location

If necessary you can restore one or more of your repository by following the instructions below.

Restore a backup

  1. Open 2c8 Modeling Tool
  2. Click on the tab ”Local”
  3. Go to ”Tools – Restore repositories” in the menu
  4. Find the backup file and click on “Open”
  5. Make sure all repositories you would like to restore is selected
  6. Click on “Restore”

You will find your restored repositories under the tab “Local”. Note that if the repository already exists, the backup will overwrite the existing one. To avoid overwriting repositories, change the name of the repository before you click on “Restore”.

Are you about to change computer och taking over a colleagues license and wonder how you get access to local repositories? There are two methods you can use:

  1. Create a backup of your local repositories, read about how here.
  2. Use the export/import feature described below.

Export:

  1. Open your repository
  2. Select “File – Export – Export content…” from the top menu
  3. Select “Export everything and save the export file in a known location
  4. Share the export file with your colleague, for instance by email or a shared network area.

Import:

  1. Open a repository (new or existing)
  2. Select “File – Import – Import content…” from the top menu
  3. Browse to and select the export file
  4. Click “Next” in the dialog. You can choose to only overwrite existing content if it is older, or to always overwrite existing content with the content from the export file. For an empty repository, this choice does not matter. Click “Next” again and stick with the default options if you are unsure.
  5. Click on “Finish”.

In order for a 2c8 Lite user to see models in a repository on a shared server, an administrator user in 2c8 Modeling Tool has to assign models to the user.

  1. The 2c8 Lite user must be added to the current repository by a user of 2c8 Modeling Tool. This is done under “Users and Rights” in the Repository Manager.

  2. The 2c8 Modeling Tool user then need to open the current repository. Go to Workflow (Browser – Double click on Workflow). Select current models, right-click and set the user(s) who will be the maintainers, reviewers and/or approvers.
    Note that the different Workflow roles can be held by more than one user, for example, there may be more than one maintainer.

Load More

Publish

If all items of a list is not visible in the top menu of a web publication, you can show the list as a popup instead of a drop-down menu.

To change this setting:

  1. Select “Tools – Publish” from the menu
  2. Edit you web profile with the pen icon
  3. Select “Layout – Menu”
  4. Select your list and edit with the pen icon

List in menu as popup

This can be due to different reasons, but a common explanation is that models are filtered because of a selection of models in the web profile. Edit the web profile by selecting “Tools – Publish” in the menu and then the pen icon. Select “Filter- Models”.

The option “All models” will include all models in the web publication. You can also make a selection of models by using the option “Select”. If you want to include breakdown models from your selection you need to check “Include breakdowns to other models”.

webprofile-model-filter-en

If your desired models are not included in the web publication after you checked your selection of models, troubleshoot by using the following list:

  1. Are you publishing the correct language?
  2. Are you publishing only the latest approved versions of models? If yes, are your models approved?
  3. Are you publishing only models with a specific status? If yes, do your models have the correct status?
  4. Are you publishing only models with a specific category? If yes, do your models have the correct category?
  5. Are you publishing to the correct location?

If you activate the popup in your web profile and the chose to just show the field “Document links” in the popup, the document link will open directly when you click an object in the web publication that has exactly one document link connected to it:

Activate popup

Add field to popup

If you only want this functionality for a specific object type (e.g. document objects), first change to the desired objekt type in the dropdown menu:

Settings for specific object type

The most common reason for warnings when publishing to the web is that there is a link to an object, model or document link that has been removed from the repository. The link is usually located in the description text for another object or model.

In the following example we get a warning when we publish that tells us that “Perform outdoor job” is referring to a removed document link:

Publish warning 1

“Perform outdoor job” can be an object or a model. In our example there is an object with that name. If we take a look at the description of the object we can see that we have text that is linked to a document link. The document link is no longer in the repository (it has been removed).

Publish warning 2

Select the text and either choose to link the text to a new document link (the “Chain” icon) or remove the link (the “Broken chain” icon). Then the warning will disappear the next time we publish.

Print from web pages

When publishing to web pages, it is possible to add a button for report attachments that can be printed, where the content of the reports is controlled by a report profile chosen in your web profile.

Choose a report profile for printing

The example below shows how to create a report of size A4 in landscape orientation with just an image of each model as the content.

Open the publish dialog and create a new report profile. Use an appropriate name for the report profile to make it easy to remember the purpose of the profile later.

In the report profile, change the orientation of the page to “Landscape” in the “Layout” section.

Go to the tab ”Models” and delete the field ”Model Contents” by clicking the cross. This will have the effect that no symbols will be listed below the image of each model. Press “Ok” to exit the settings dialog.

The report that is created will look like this:

Activate button for report printing in web profile

To activate the report attachments feature in your web pages open your web profile and go to the “Layout” section and the “Menu” tab. This is where you can control what is shown in the menu of the web pages.

Check the ”Create report” checkbox and choose which report profile to use in the dropdown menu. Then choose if you want attachments as PDF documents, Word documents or both. By clicking the icon to the right of each document format you can choose which icon to use in the menu. You will for instance find the print icon here.

Click ”Ok” to save your settings and exit the settings dialog.

You can now publish and get report attachments as PDF or Word documents that can be used for printing. Please note that the publish process will take longer than before since now a report is created for each model that is part of the web pages created.

 

To getting started with the responsive web profile install the plug-in “Responsive Web”.

Read about install plug-in here.

Learn how to redirect mobile users to the responsive published material and let computer users see the regular material here.

Customize your responsive web profile

To customize your responsive web profile go to “Tools – Publish..” in the menu and double click on your profile.

If you do not have a responsive web profile among your profiles just add by clicking on the plus-icon.

Profile

Under the tab “Profile” set name, description and choose your start model.

Filter

Under the tab ”Filter” select models witch will follow to your published material. Your will also manage layers and languages here.

Layout

Under the tab ”Layout -Top panel” you set the layout on your top panel.

The top panel is divided into two areas. The top area is marked with an orange frame (1) and the lower part is marked with a green frame.

  1. Set your logo, build you menu and search functionality.
  2. Show the breadcrumbs, language, layers and print functionality.

Under the tab ”Models” set the information you want to visualize for the published models. Choose among the “Available components”.

Notice! This applies to models that follow “Default layout”. If information is missing in the published material, it may be because that model has other setting. Make sure to check your models, if they are following the “Default Layout” or if they have other settings.  Models that are bold in the dropdown have their own settings otherwise the follow the “Default layout”.

The same principles applies for the tab “Symbols” as for the previous tab “Model”.

If your web publication looks strange in Internet Explorer, check your settings for Compatibility View. In Internet Explorer, select the Tools button and then select Compatibility View settings. Uncheck the checkbox “Display intranet sites in Compatibility View”.

The web publication created by 2c8 Modeling Tool is a web application1 that is built to be placed on and shown by a web server like Microsoft IIS or Apache HTTP Server. Our recommendation is that a web publication is placed on a web server since this will provide optimal performance when the web publication is shown to the end user in the web browser.

A web publication can also be shown directly via disk, for instance on a computers C: or a network drive with a device name like G: Please note that the performance may suffer if the speed to the disk is slow due to the network or the disk itself.

A web publication can be shown from Sharepoint Online, but requires some manual steps. Read more in our instruction 2c8 and Sharepoint Online.

Cloud services for file storage such as DropboxGoogle Drive or Microsoft OneDrive can be used to share (sync) a web publication between users, but not to show a web publication directly from the cloud since these services don’t provide a web server service. This means that you cannot view a web publication from the web interface of these services, but you can sync the files of the web publication to your computer and then view the web publication by opening the file “index.html” in Windows Explorer.

Services offering the customer to create their own websites but not to upload custom javascript files (e.g. Google Sites) cannot be used to show a web publication from 2c8 Modeling Tool.

1 The web publication from 2c8 Modeling Tool consists of a file index.html and a folder pages-{TIMESTAMP} which among others contain the following file types:html, css, xml, javascript and png.

Your web browser has probably saved a previous version of the web publish.

Try emptying the cache in your web browser. By emptying the cache you are forcing the web browser to download the latest version of the web publish.

In most web browsers you can open the dialog for emptying the cache by clicking CTRL+SHIFT+DELETE.

To adjust the color and size of headings and text in descriptions and how they are displayed in the published material you need to make the adjustments in the web profile you are using. This makes all descriptions on all objects and models use the same formatting.

Note that you can make different adjustments for every web profile you have.

 

If you open “Properties” – “Description” on a model or object there is a drop down that has the same name as your web profile. Choose a profile and the text in the description will preview what the text will look like in your published material.

To change these settings:

1. Select the web profile you want to use and click on the pen to edit (“Tools” – “Publish”).

2. Go to “Appearance” – “Theme”

3. Choose descriptions and adjust desired settings. (Normal = Paragraphs)

4. These settings correspond to the formatting options you see in the description dialog.

 

The size of the text is set in e.m’s. If you are used to other units, please see the table below:

Note that if you change fonts, size and color in the description dialog it will override the adjustments you have made in the web profile.

Load More

Common

After logging in to a server, click the ”Users and Permissions” icon in the toolbar in the Repository Manager.

Expand the ”Server users” node to show server users. Select your user and enter a new password in the input fields to the right.

 

After you entered your new password, click the ”Save” button and then click the “Users and permissions” icon in the toolbar again to return to the list of repositories.

 

Install the plugin by going to “Tools – Settings..” in the menu. Choose the tab “Plug-in – Avilable” in the popup. Select your plug-in and click on “Install..”.

When a plug-in is installed it will show up under the tap “Installed”.

Go to “Tools – Color profiles..” in the menu to set you color profile. If you want to change your profile make sure that the new profile is selected in the drop down menu before clicking OK.

 

Be aware that you can create your own color profiles and if you work on a server your color profile will be available for all the users on the server.

In Administration Tool you can import color profiles if you want to change the default color profile.

To change color on a single symbol right click on the current symbol and choose “Appearance..”. When you are done press OK.  Remember that these changes just applies on current symbol.

To use 2c8 Modeling Tool, the licensee must activate his license. There are two ways to activate a license depending on whether your computer has access to the Internet or not.

1. License Activation over the Internet

When you start the program for the first time, enter the license key you received from 2conciliate.

Paste the five-digit license key and click Next.

Enter name and contact details and click Next.

Enter the department you belong to to facilitate your billing.

 

Click next.

2. Activation via file if internet access is missing

If you do not have access to the internet when you activate your license, a choice will pop up to activate using a file from another computer that has Internet access.

Activation via file is done in three steps, starting with clicking the link you will use for activation.

When you click on the link, a web browser opens with the activation link in the address bar. Select the text that is in the address bar and copy it to, for example Notes, so you can include and run the activation from a computer that has internet access.

When you open the address from a computer that has internet access, the following forms will be available.

Fill in your information and click “Download activation file”, you will be notified of a downloaded file. This file should be used to enable the application on the computer that lacks internet access.

Save the file. Click on the import icon in the activation dialog and select your activation file.

 

Done!

If you have any questions or concerns about activation, please contact support at support@2c8.com.

 

 

 

 

 

Download the software and install it. At first program start you will have to enter a licensekey, which you can request by filling out the form here.

When you enable the setting “Show breakdowns” in the navigation panel (see image) a model will show up both in the list for its model type, and also where the model is used as a breakdown. In the example below, the model “Main process” is shown under the “Process model” heading since it is of type process model, and as a breakdown under the general model “Start”, since the “Start” model contains a breakdown to the model “Main process”.

FAQ Model Tree

If you get the following error message:

Please check:

  1. Check that you have a working internet connection.
  2. If the server was added manually, go to “Tools – Settings” and the “Servers”:
  3. Doubleclick the server and check that hostname, http-port and the “Use SSL” settings are correct.
  4. If the server is a customer internal server, check with your IT if there is any problems with the server (is it up and running?)
  5. If the server is hosted by 2c8, contact our support.

Are you about to change computer och taking over a colleagues license and wonder how you get access to local repositories? There are two methods you can use:

  1. Create a backup of your local repositories, read about how here.
  2. Use the export/import feature described below.

Export:

  1. Open your repository
  2. Select “File – Export – Export content…” from the top menu
  3. Select “Export everything and save the export file in a known location
  4. Share the export file with your colleague, for instance by email or a shared network area.

Import:

  1. Open a repository (new or existing)
  2. Select “File – Import – Import content…” from the top menu
  3. Browse to and select the export file
  4. Click “Next” in the dialog. You can choose to only overwrite existing content if it is older, or to always overwrite existing content with the content from the export file. For an empty repository, this choice does not matter. Click “Next” again and stick with the default options if you are unsure.
  5. Click on “Finish”.

The most common reason to why a model does not appear after an import is that the model existed earlier in the repository but has been removed. If the choice “Overwrite existing content if it is older” was selected during the import the action “Remove model” may have been the latest event for the model and it will not be imported. To verify if this is the problem, run the import again and look under the tab “Details” when the import has finished:

To force the import of the model, run the import again and select the option “Always overwrite existing content”:

There are different scenarios where you might want to move a license from one person to another. For example if someone goes on maternity leave, quits or switch position.

To move a license to another person, send an email to invoice@2c8.com or fill out this form and choose “Questions about licenses or invoices” under “Type”. It’s important that you send us contact information both of the person who is taking over the license and also of the person that has the license today.

We charge an administrative fee to move a license to another person. Exceptions are if the person goes on maternity leave, gets sick and have to leave work or quits from the organisation. For more information, please send an email to invoice@2c8.com.

A draft model in 2c8 Lite, that is, a model located in the “My models” area, is sent for maintenance when the 2c8 Lite user clicks on the workflow icon and then on “Send model”:

To import the draft model to your desired repository an administrator user in 2c8 Modeling Tool with the permission “Accept drafts” need to import the draft to the repository:

1. Open the Dashboard in the Repository Manager
2. Double-click on the draft model in the blue area “New models in 2c8 Lite”
3. Choose the repository to import to and click “Select”
4. Choose the model type, set Workflow roles and then click “Import draft”

Go to “Help -Support” in the menu.

Click on “Log file” and save on a appropriate location on your computer.

Attach in a mail to support@2c8.com

Load More

 

 

2c8 Lite

Quickdraw is activated in the toolbar and is used to quickly build a model from existing symbols.

Quickdraw icon

Hold the mouse over a symbol to show arrows in the directions where suggestions for relations to new symbols exist. Hold the mouse over an arrow to show the suggested symbols in that direction. When you click on a symbol you will get to choose a title in the same way as when you add a symbol by clicking in the model.

The keyboard shortcut to toggle Quickdraw is Ctrl+Q. If you want different suggestions in Quickdraw, this can be configured from 2c8 Administration Tool.

The 2c8 Support may ask you for the log file from 2c8 Lite. Use the following steps to access and send the log file:

1. Open a model
2. Click the cube and select Support
3. Click “Log file” and save the file on your computer
4. Attach the file in a mail to the 2c8 support

There are different scenarios where you might want to move a license from one person to another. For example if someone goes on maternity leave, quits or switch position.

To move a license to another person, send an email to invoice@2c8.com or fill out this form and choose “Questions about licenses or invoices” under “Type”. It’s important that you send us contact information both of the person who is taking over the license and also of the person that has the license today.

We charge an administrative fee to move a license to another person. Exceptions are if the person goes on maternity leave, gets sick and have to leave work or quits from the organisation. For more information, please send an email to invoice@2c8.com.

In order for a 2c8 Lite user to see models in a repository on a shared server, an administrator user in 2c8 Modeling Tool has to assign models to the user.

  1. The 2c8 Lite user must be added to the current repository by a user of 2c8 Modeling Tool. This is done under “Users and Rights” in the Repository Manager.

  2. The 2c8 Modeling Tool user then need to open the current repository. Go to Workflow (Browser – Double click on Workflow). Select current models, right-click and set the user(s) who will be the maintainers, reviewers and/or approvers.
    Note that the different Workflow roles can be held by more than one user, for example, there may be more than one maintainer.

To be able to create more types of models in 2c8 Lite, an administrator needs to change the Lite-configuration in Administration Tool in Modeling Tool.

  1. An administrator in Modeling Tool needs to open Administration Tool. “Tools – Start Administration Tool…” in the menu in the Repository Manager.

2. Log in to see the configurations and edit the one called “Lite” which is located in the lower box under “Server repository configurations”.

3. Choose “Models”. In the box “Used models” the models available in 2c8 Lite are visible.

4. Move the types of models you want to make available in 2c8 Lite by using the arrows between the boxes “Excluded models” and “Used Models”. Don’t forget to save when you are done!

Load More

 

2conciliate Business Solutions